milestones.xml - not containing all milestones

Nikolaj Have's Avatar

Nikolaj Have

02 Mar, 2010 10:36 AM

I am getting a list of all my milestones:

.lighthouseapp.com/milestones.xml?_token=

This seemed to work fine, but then it puzzled me that some milestones were missing.

I have now double-checked this one milestone: It appears in the web interface, but not in the XML file. I even searched for the milestone ID ...

How come? What did I miss? ... How to move on from here?

Thanks!
Nik

  1. 1 Posted by Nikolaj Have on 02 Mar, 2010 10:40 AM

    Nikolaj Have's Avatar

    The link I use for the XML is ...

    [my-account].lighthouseapp.com/milestones.xml?_token=[my-token]

  2. 2 Posted by Rick on 02 Mar, 2010 06:49 PM

    Rick's Avatar

    How many milestones are there? It may show up on page 2 if there are more than 30. Add a page=2 parameter to the URL.

  3. 3 Posted by Nikolaj Have on 02 Mar, 2010 07:14 PM

    Nikolaj Have's Avatar

    Ahaa! ... A hidden feature! :-) ... Yes, there are more than 30.

    So I just use limit=999 or is there a "real" way to retrieve all?

  4. 4 Posted by Rick on 02 Mar, 2010 10:15 PM

    Rick's Avatar

    Nope. We have a full Lighthouse export feature in the works, however.

  5. Rick closed this discussion on 02 Mar, 2010 10:15 PM.

Discussions are closed to public comments.
If you need help with Lighthouse please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac