Login conflicts with Mozilla Weave somehow

Su's Avatar

Su

03 Aug, 2009 06:15 PM

Following up from Twitter, I managed to dig up a little extra in the meantime.

I'm running Fx3.5 with Weave0.5.

When I try to log in with a regular account, I get forced through:
chrome://weave/content/openid-wait.xul
...and then end up at an error screen for account creation If I try to log in from the main LH home page, I just get dumped right back to the home page with no change in status at all.

Disabling the Weave extension completely resolves this, but I'm unsure at this point whether this is ultimately a problem with Weave or your login process doing something to trigger it, though, and have no real clue how to go about finding out. I'm digging around some but haven't run across any similar mentions.
Ideas?

  1. 1 Posted by Will Duncan on 03 Aug, 2009 06:19 PM

    Will Duncan's Avatar

    I'm sorry, we don't currently support Mozilla Weave.

  2. 2 Posted by Su on 03 Aug, 2009 06:21 PM

    Su's Avatar

    That's understandable, and I wouldn't ask you to. But I'm not sure that Weave is even supposed to be coming into play, unless something's triggering it.

    I've found this previous discussion, which is similar, but there's still the confusing bit that I'm not using OpenID to log in, like this guy. I don't even have one set up.

    So, unless something about your login process still crams us through something OpenID-ish(?) I would assume I shouldn't be affected by whatever's going on over there. Or am I missing something?

  3. 3 Posted by Rick on 03 Aug, 2009 06:59 PM

    Rick's Avatar

    It looks like Weave is detecting our open id form fields and trying to force its own open id login. I'd prefer to just disable it altogether -- I'm not too thrilled it decides to modify the site and break it for most users.

Discussions are closed to public comments.
If you need help with Lighthouse please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac