When signing in with myopenid, a new email is required every time

esben's Avatar

esben

17 Jun, 2009 07:46 AM

When I sign in the http://esbenmosehansen.myopenid.com/, lighthouse claims that my email is empty every time, and that I need to enter one. The form is prefilled with my email, [email blocked]. If I try to use that, it claims that that email is already taken (probably by me). If I change it to something else, it works, until I attempt to sign in next time. Then it requires a new email from me --- none of the ones I've already used works (they are all "already used"). Which leads me to suspect that I have about 3 accounts by now.

It might be because I haven't entered any user data at myopenid. I've tried that now, and now it just claims that the email was already used the first time, instead of complaining that it is empty. Just a guess though.

  1. 1 Posted by Rick on 17 Jun, 2009 02:37 PM

    Rick's Avatar

    Lighthouse doesn't magically link up whatever some OpenID server says to your user profile. You either have to create it from the OpenID login, or set the OpenID url in your user profile settings.

  2. 2 Posted by Esben Mose Hans... on 26 Jun, 2009 10:04 AM

    Esben Mose Hansen's Avatar

    The trouble is that I cannot log in because it complains about the email, so setting it in my account is not so easy. I suppose I could create yet another email address to try to change this, but honestly I am getting a bit fed up with that game. If it needs the openid URL to function, why didn't it register the url when I created the profile, or one of the 3 times I have logged in since? I suspect it is really three different accounts now, but I have no way to tell.

  3. 3 Posted by Rick on 26 Jun, 2009 05:21 PM

    Rick's Avatar

    If you have an existing Lighthouse account, you can set an OpenID url for it in your user profile.

  4. 4 Posted by Esben Mose Hans... on 29 Jun, 2009 11:57 AM

    Esben Mose Hansen's Avatar

    How, exactly? I cannot log in due to this issue :)

    When I created the account, I was logged in, and I could have set it at that time, I imagine. But now that I am no longer logged in, this is not possible.

  5. 5 Posted by Rick on 29 Jun, 2009 12:00 PM

    Rick's Avatar

    You can use the reset password feature on the login page to get back
    into your profile.

  6. 6 Posted by Esben Mose Hans... on 03 Jul, 2009 11:41 AM

    Esben Mose Hansen's Avatar

    I have tried that several times, but I always get

    Whoops, looks like you have a bad or outdated token. Use the password reset function on the login screen to get a new one.

    when following the link sent by the email

  7. 7 Posted by Rick on 04 Jul, 2009 05:37 AM

    Rick's Avatar

    It expires in an hour or so, so you have to click it right after receiving it.

  8. 8 Posted by Esben Mose Hans... on 04 Jul, 2009 06:55 AM

    Esben Mose Hansen's Avatar

    I clicked within a few minutes, each of the 3 times I tried.

  9. 9 Posted by Rick on 04 Jul, 2009 04:36 PM

    Rick's Avatar

    What email are you using, `[email blocked]`? I just tried it
    and it worked fine. If you submit the reset password form multiple
    times, it will change your activation token, so the first email token
    will be immediately invalidated.

  10. 10 Posted by Cedric on 07 Jul, 2009 03:54 PM

    Cedric's Avatar

    I'm seeing the same problem, just trying to log-in with a standard email/password. Seems like there is some sort of login bug. My account email and password has not changed in a while but now I can't log in. This is what I'm seeing:

    1) Going to my bookmarked ticket queue.
    2) Getting a "this is not a public project" message and the login (but it defaults to the openid login)
    3) I switch to the email login and submit. 4) It sits at this URL for a bit with a dinosaur animated image: chrome://weave/content/openid-wait.xul 5) Then I get the following error: OpenID verification failed: Invalid openid.mode: cancelhttps://polar.lighthouseapp.com/login?remember_me=1

    (Also, this isn't happening anymore, but like the previous poster, I was originally getting an email format error on a create new user form.)

  11. 11 Posted by Cedric on 07 Jul, 2009 03:59 PM

    Cedric's Avatar

    Actually, maybe this is due to running Firefox 3.5? That's the only thing that has changed that I can think of. I just tried loggin in with Safari and it works fine.

  12. 12 Posted by Rick on 07 Jul, 2009 09:16 PM

    Rick's Avatar

    Perhaps... the error makes it sound like it's not something we're
    doing: "OpenID verification failed: Invalid openid.mode: cancel"

  13. 13 Posted by Dan Harrelson on 13 Jul, 2009 05:02 PM

    Dan Harrelson's Avatar

    I am seeing the same bug as @Cedric. It appears that the login flow is detecting that I have Weave installed on Firefox 3.5 and is forcing me down the OpenID path. My account only has and email/passwd combo and therefore I am prompted to created a new account with the Weave OpenID. Safari works just fine.

    The animated dino is the Mozilla loading animation use when validating Weave authentication.

  14. 14 Posted by Will Duncan on 17 Jul, 2009 01:13 AM

    Will Duncan's Avatar

    We're still investigating the openID issue. For some reason I can't seem to replicate it very easily. sigh

    Hopefully we'll find a solution soon.

  15. 15 Posted by Dan Harrelson on 17 Jul, 2009 03:17 AM

    Dan Harrelson's Avatar

    FYI, I just upgraded to Weave 0.5pre2 and the problem still occurs.

  16. 16 Posted by Will Duncan on 17 Jul, 2009 03:23 AM

    Will Duncan's Avatar

    Thanks for the heads up on that.

  17. 17 Posted by Dan Harrelson on 27 Jul, 2009 04:31 PM

    Dan Harrelson's Avatar

    Any update on this bug? Thanks!

  18. 18 Posted by Justin Palmer on 27 Jul, 2009 05:46 PM

    Justin Palmer's Avatar

    I just tested this with and without Weave. Everything works fine without weave, so this looks like a bug in Weave that should be filed with Mozilla.

    Is anyone not using Weave and still having this issue?

  19. 19 Posted by Dan on 27 Jul, 2009 06:01 PM

    Dan's Avatar

    Hey Justin, thanks for the prompt response. You are implying that ENTP will file the bug with Mozilla, right? I certainly think that makes sense.

  20. 20 Posted by Justin Palmer on 27 Jul, 2009 06:17 PM

    Justin Palmer's Avatar

    This looks like a known issue, so I'll assume the Weave guys are aware of this. There is a temporary fix posted in the article below. It's not isolated to just LH, but seems to be an openid issue in general:

    Google groups

Discussions are closed to public comments.
If you need help with Lighthouse please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac