myopenid auth failure using Firefox 3.0.8

Eirik Dentz Sinclair's Avatar

Eirik Dentz Sinclair

22 Apr, 2009 05:40 PM

This just started happening the other day and myopenid auth works fine using Safari, so I'm not sure what is going on. Error message: signin fail

  1. 1 Posted by Rick on 22 Apr, 2009 07:30 PM

    Rick's Avatar

    It's not firefox, it happens to me too. I'm wondering if it's a myopenid issue? I've done some searching and I can't find much info on it. Maybe the ruby gem is having problems generating the necessary tokens for this 'check_authentication' call?

  2. 2 Posted by micha.niskin on 27 Apr, 2009 03:01 PM

    micha.niskin's Avatar

    I get the same error. I use aol's openid server.

  3. 3 Posted by Will Duncan on 28 Apr, 2009 08:05 AM

    Will Duncan's Avatar

    Micha, thank you for your feedback. We're still looking into the issue, it appears to be occurring at random for us when we try to replicate it. Are you seeing it consistently?

  4. 4 Posted by micha.niskin on 28 Apr, 2009 03:02 PM

    micha.niskin's Avatar

    Hi Will, Yes, it happens consistently for me. I'm actualy using Fluid.app v0.9.6.

    On Tue, Apr 28, 2009 at 4:06 AM, Lighthouse Support < [email blocked]> wrote:

  5. 5 Posted by Nei Ferree on 29 Apr, 2009 08:07 PM

    Nei Ferree's Avatar

    My question to those familiar with MyOpenID authentication process.

    Is the phone verification process required for each (initial) session w/ MyOpenID (and) does the 'standard' OpenID authentication session utilize the same process?

    Thanks,

    Neil

  6. 6 Posted by Rick on 29 Apr, 2009 08:30 PM

    Rick's Avatar

    Nei: sorry, you'll have to post that question to MyOpenID support.

  7. 7 Posted by Neil Ferree on 29 Apr, 2009 08:49 PM

    Neil Ferree's Avatar

    Thanks for the pointer Rick, much appreciated.

    On Wed, Apr 29, 2009 at 1:38 PM, Lighthouse Support < [email blocked]> wrote:

  8. 8 Posted by levin.alexander on 30 Apr, 2009 01:18 AM

    levin.alexander's Avatar

    I got a comment by Jonathan Daugherty from myopenid.com on: http://skitch.com/levinalex/bpt9r/myopenid-lighthouse#b14j

    "Generally speaking, this is a configuration problem (usually store-related) with the OpenID library in question. Feel free to contact us at support AT myopenid DOT com!"

  9. 9 Posted by Rick on 30 Apr, 2009 01:54 AM

    Rick's Avatar

    Apparently there was a security update to the ruby-openid gem. I suppose it was urgent enough that the servers were fixed before fixed ruby gems could go out. Someone just let me know about it, and I see there's a new version of the gem out now. It sounds like this is somehow related to the recent OAuth security issue. I'll do a bit more research once I'm sure this actually works.

    So, please let me know if you still get this error on Lighthouse. If it's good I'll make the same upgrade to Tender as well.

  10. 10 Posted by Rick on 30 Apr, 2009 01:56 AM

    Rick's Avatar

    False alarm, it still happens :(

  11. 11 Posted by Eirik Dentz Sin... on 08 May, 2009 05:32 AM

    Eirik Dentz Sinclair's Avatar

    You're right it doesn't appear to be Firefox specific as I first suspected. In fact I can't find a pattern right now. Sometimes it works, sometimes it doesn't. At first I thought it was the 'remember me' checkbox, but I've succeeded with and without it checked and failed as well.

    Additionally, one of my successful sign-ins was accompanied by the attached LH error message.

  12. 12 Posted by Rick on 09 May, 2009 01:42 AM

    Rick's Avatar

    It's some internal OpenID issue, and it only happens in production. Works on my local machine and even staging.

Discussions are closed to public comments.
If you need help with Lighthouse please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac