Ruby lighthouse-api gem uses removed ActiveSupport core extension

Simon Coffey's Avatar

Simon Coffey

25 May, 2012 02:14 PM

Hi,

The lighthouse-api gem uses a core extension from ActiveSupport that's been removed as of version 3.2, Module#attr_accessor_with_default. I'm not sure if this gem is being actively maintained, but since the code isn't hosted publically, I've cloned the gem and pushed a patch here.

Hope this is of use.

Cheers,
Simon

  1. 1 Posted by Nicole on 25 May, 2012 07:20 PM

    Nicole's Avatar

    Simon -

    It looks like the original repo isn't being maintained by the owner any longer (and they don't work for us anymore), so we've forked it and you can make a pull request with your changes to for https://github.com/entp/lighthouse-api/.

    Thanks for giving us a nudge!
    Nicole

  2. 2 Posted by Simon Coffey on 25 May, 2012 09:03 PM

    Simon Coffey's Avatar

    Thanks Nicole - pull request submitted...

  3. 3 Posted by Nicole on 31 May, 2012 03:48 PM

    Nicole's Avatar

    Simon -

    Awesome! I've let our developers know the pull request is there and they'll take a look as soon as they can.

    Thanks again!
    Nicole

  4. Nicole closed this discussion on 31 May, 2012 03:48 PM.

Discussions are closed to public comments.
If you need help with Lighthouse please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac